Prerequisites for Linux

From ASCEND
Jump to: navigation, search

See the page Building ASCEND for more platform-specific advice on prerequisites for ASCEND.

To Build ASCEND

You can usually just use the default versions of these that come with current versions of Linux. But just check them, anyway:

  • gcc and g++ (3.x or 4.x)
  • gfortran or g77 (we are recommending gfortran, because a FORTRAN-90 compiler is required if you want to build CONOPT)
  • flex
  • bison
  • python 2.4 or newer, including 'dev' package or similar
  • scons (1.x or 0.98.x)
  • swig (>=1.3.24). Some probs reported with 1.3.39.
  • sundials (>=2.2.0) or note that we have an RPM
  • Tcl/Tk 8.3 or newer
  • Tktable 2.8 or newer
  • graphviz (optional)
  • blas (optional, for use by LSODE solver; ASCEND also can build its own)

OpenSUSE is very out of date with SCons. You will not be able to use their version (as of May 2007).

To Run ASCEND

The PyGTK GUI:

  • gtk+
  • pygtk
  • matplotlib
  • numpy
  • libsundials (see Building ASCEND for note regarding Ubuntu Edgy)
  • IPython (optional)
  • graphviz (optional)

To run the Tcl/Tk GUI:

  • Tcl/Tk 8.3.x or 8.4.x (whichever was used for the build)
  • TkTable 2.8 or 2.9
  • xgraph

See also Prerequisites for Windows.